High database latency

Incident Report for Column

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 19:46 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 07, 2026 - 19:32 UTC

Identified

We are experiencing high database latency leading to elevated API timeouts. We have identified the issue and working on a fix.
Posted Apr 07, 2026 - 19:28 UTC
This incident affected: Production.