Increased Endpoint Latency

Incident Report for Column

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 23:03 UTC

Identified

We are triaging some database latency which is leading to occasional API endpoint timeouts.
Posted Mar 27, 2026 - 19:50 UTC
This incident affected: Production.