International Wires

Incident Report for Column

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 07:26 UTC

Update

This incident has been resolved.
Posted Nov 24, 2025 - 07:26 UTC

Update

The interruption has been resolved due to an issue with the SWIFT network
Posted Nov 24, 2025 - 07:25 UTC

Investigating

We are currently investigating this issue.
Posted Nov 24, 2025 - 05:15 UTC
This incident affected: Production.